System.Diagnostics.Debug 4.0.10-beta-23019

Provides classes and attributes that allows basic interaction with a debugger. Commonly Used Types: System.Diagnostics.Debug System.Diagnostics.DebuggerStepThroughAttribute System.Diagnostics.Debugger System.Diagnostics.DebuggerDisplayAttribute System.Diagnostics.DebuggerBrowsableAttribute System.Diagnostics.DebuggerBrowsableState System.Diagnostics.DebuggerHiddenAttribute System.Diagnostics.DebuggerNonUserCodeAttribute System.Diagnostics.DebuggerTypeProxyAttribute

Showing the top 20 packages that depend on System.Diagnostics.Debug.

Packages Downloads
System.Diagnostics.DiagnosticSource
Provides Classes that allow you to decouple code logging rich (unserializable) diagnostics/telemetry (e.g. framework) from code that consumes it (e.g. tools) Commonly Used Types: System.Diagnostics.DiagnosticListener System.Diagnostics.DiagnosticSource 7e3dbdb95b30650eabade0ac73a10b22d4dbe8b3 When using NuGet 3.x this package requires at least version 3.4.
3
System.Diagnostics.DiagnosticSource
Provides Classes that allow you to decouple code logging rich (unserializable) diagnostics/telemetry (e.g. framework) from code that consumes it (e.g. tools) Commonly Used Types: System.Diagnostics.DiagnosticListener System.Diagnostics.DiagnosticSource When using NuGet 3.x this package requires at least version 3.4.
3
System.Security.Principal.Windows
Provides classes for retrieving the current Windows user and for interacting with Windows users and groups. Commonly Used Types: System.Security.Principal.WindowsIdentity System.Security.Principal.SecurityIdentifier System.Security.Principal.NTAccount System.Security.Principal.WindowsPrincipal System.Security.Principal.IdentityReference System.Security.Principal.IdentityNotMappedException System.Security.Principal.WindowsBuiltInRole System.Security.Principal.WellKnownSidType When using NuGet 3.x this package requires at least version 3.4.
2
System.Diagnostics.TraceSource
Provides classes that help you trace the execution of your code. Developers should prefer the classes in the ETW-based System.Diagnostics.Tracing package. Commonly Used Types: System.Diagnostics.TraceListener System.Diagnostics.TraceLevel System.Diagnostics.TraceSource System.Diagnostics.TraceEventType System.Diagnostics.DefaultTraceListener System.Diagnostics.Trace When using NuGet 3.x this package requires at least version 3.4.
2
Portable.BouncyCastle
BouncyCastle.Crypto is a cryptography API providing: -Generation and parsing of PKCS#12 files. -X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. -PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. -Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. -Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC. -Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). -Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte. -Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA. -Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1. -Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool. -Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA. -Key Agreement: Diffie-Hellman and EC-DH. -Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3. -PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2. -OpenPGP (RFC 2440) -Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. -Online Certificate Status Protocol (OCSP, RFC 2560). -Time Stamp Protocol (TSP, RFC 3161). -TLS/SSL Client with support for client side authentication. Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR
2
System.Net.Http
Provides modern classes for sending HTTP requests and receiving HTTP responses from a resource identified by a URI. Commonly Used Types: System.Net.Http.HttpResponseMessage System.Net.Http.DelegatingHandler System.Net.Http.HttpRequestException System.Net.Http.HttpClient System.Net.Http.MultipartContent System.Net.Http.Headers.HttpContentHeaders System.Net.Http.HttpClientHandler System.Net.Http.StreamContent System.Net.Http.FormUrlEncodedContent System.Net.Http.HttpMessageHandler
2
System.Security.Principal.Windows
Provides classes for retrieving the current Windows user and for interacting with Windows users and groups. Commonly Used Types: System.Security.Principal.WindowsIdentity System.Security.Principal.SecurityIdentifier System.Security.Principal.NTAccount System.Security.Principal.WindowsPrincipal System.Security.Principal.IdentityReference System.Security.Principal.IdentityNotMappedException System.Security.Principal.WindowsBuiltInRole System.Security.Principal.WellKnownSidType
2
System.Diagnostics.DiagnosticSource
Provides Classes that allow you to decouple code logging rich (unserializable) diagnostics/telemetry (e.g. framework) from code that consumes it (e.g. tools) Commonly Used Types: System.Diagnostics.DiagnosticListener System.Diagnostics.DiagnosticSource When using NuGet 3.x this package requires at least version 3.4.
2
System.Runtime.WindowsRuntime
Provides extensions methods that improve interoperation between managed code and the Windows Runtime. Commonly Used Types: System.WindowsRuntimeSystemExtensions System.IO.WindowsRuntimeStorageExtensions System.IO.WindowsRuntimeStreamExtensions System.Runtime.InteropServices.WindowsRuntime.AsyncInfo System.Runtime.InteropServices.WindowsRuntime.WindowsRuntimeBuffer When using NuGet 3.x this package requires at least version 3.4.
2
xunit.assert
Includes the assertion library from xUnit.net (xunit.assert.dll). Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows 8 - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
2
Microsoft.VisualStudio.Validation
Common input validation and state verification utility methods.
2
System.Xml.XDocument
Provides the classes for Language-Integrated Query (LINQ) to Extensible Markup Language (XML). LINQ to XML is an in-memory XML programming interface that enables you to modify XML documents efficiently and easily. Commonly Used Types: System.Xml.Linq.XElement System.Xml.Linq.XAttribute System.Xml.Linq.XDocument System.Xml.Linq.XText System.Xml.Linq.XNode System.Xml.Linq.XContainer System.Xml.Linq.XComment System.Xml.Linq.XObject System.Xml.Linq.XProcessingInstruction System.Xml.Linq.XDocumentType
1
Microsoft.TestPlatform.AdapterUtilities
Includes helpers for the Test Platform's modern functionality such as standardized fully qualified names and hierarchical test case names.
1
Moq
Moq is the most popular and friendly mocking framework for .NET
1
Microsoft.Extensions.DependencyModel
Abstractions for reading `.deps` files.
1
System.Collections.Concurrent
Provides several thread-safe collection classes that should be used in place of the corresponding types in the System.Collections.NonGeneric and System.Collections packages whenever multiple threads are accessing the collection concurrently. Commonly Used Types: System.Collections.Concurrent.ConcurrentDictionary<TKey, TValue> System.Collections.Concurrent.ConcurrentQueue<T> System.Collections.Concurrent.ConcurrentBag<T> System.Collections.Concurrent.BlockingCollection<T> System.Collections.Concurrent.ConcurrentStack<T>
1
AutoMapper
A convention-based object-object mapper. AutoMapper uses a fluent configuration API to define an object-object mapping strategy. AutoMapper uses a convention-based matching algorithm to match up source to destination values. Currently, AutoMapper is geared towards model projection scenarios to flatten complex object models to DTOs and other simple objects, whose design is better suited for serialization, communication, messaging, or simply an anti-corruption layer between the domain and application layer.
1

.NET Framework 4.6

  • No dependencies.

.NETPlatform 5.0

Version Downloads Last updated
4.3.0 0 11/15/2016
4.3.0-preview1-24530-04 0 10/24/2016
4.0.11 0 06/27/2016
4.0.11-rc2-24027 0 05/16/2016
4.0.11-beta-23516 0 11/18/2015
4.0.11-beta-23409 0 10/15/2015
4.0.11-beta-23225 0 09/01/2015
4.0.10 0 07/29/2015
4.0.10-beta-23109 0 07/27/2015
4.0.10-beta-23019 1 10/25/2026
4.0.10-beta-22816 0 04/24/2015
4.0.10-beta-22605 1 10/26/2026
4.0.10-beta-22416 0 01/16/2015
4.0.10-beta-22231 0 11/11/2014
4.0.0 0 07/29/2015
4.0.0-beta-23109 0 07/27/2015
4.0.0-beta-23019 0 06/30/2015