System.Threading.Tasks 4.3.0
Provides types that simplify the work of writing concurrent and asynchronous code.
Commonly Used Types:
System.Threading.Tasks.Task<TResult>
System.Runtime.CompilerServices.TaskAwaiter<TResult>
System.Threading.Tasks.TaskCompletionSource<TResult>
System.Threading.Tasks.Task
System.OperationCanceledException
System.AggregateException
When using NuGet 3.x this package requires at least version 3.4.
Showing the top 20 packages that depend on System.Threading.Tasks.
| Packages | Downloads |
|---|---|
|
FSharp.Core
FSharp.Core redistributables from Visual F# Tools version 10.4 For F# 4.6
Supported Platforms:
.NET Framework 4.5+ (net45)
netstandard1.6 (netstandard1.6)
netstandard2.0 (netstandard2.0)
Commit hash: 8527f4444ac8618a2aee143be608f63c55f51325
|
3 |
|
FSharp.Core
FSharp.Core redistributables from Visual F# Tools version 10.3 For F# 4.5
Supported Platforms:
.NET Framework 4.5+ (net45)
netstandard1.6 (netstandard1.6)
netstandard2.0 (netstandard2.0)
Commit hash: 9c833d0c11ec0f546ff1b3e6a9af1440f0b7a2e7.
|
2 |
|
FSharp.Core
FSharp.Core redistributables from Visual F# 4.1.0
Supported Platforms:
.NET 4.5+ (net45)
netstandard1.6 (netstandard1.6)
|
1 |
|
FSharp.Core
FSharp.Core redistributables from Visual F# 4.1.0
Supported Platforms:
.NET 2.0 (net20)
.NET 4.0 (net40)
.NET 4.5+ (net45)
.NET Portable Profile 7 (portable-net45+netcore45)
.NET Portable Profile 47 (portable-net45+sl5+netcore45)
.NET Portable Profile 78 (portable-net45+netcore45+wp8)
.NET Portable Profile 259 (portable-net45+netcore45+wpa81+wp8)
.NET Standard 1.6 (netstandard1.6)
MonoAndroid, MonoTouch, Xamarin.iOS (portable-net45+monoandroid10+monotouch10+xamarinios10)
XamarinMac mobile (xamarinmac20)
|
1 |
|
FSharp.Core
FSharp.Core redistributables from Visual F# Tools version 10.2 For F# 4.5
Supported Platforms:
.NET 4.5+ (net45)
netstandard1.6 (netstandard1.6)
netstandard2.0 (netstandard2.0)
Commit hash: fb7f38082efdeb0e02a389c0968f40245ef67bd3.
|
1 |
|
xunit.core
Includes the libraries for writing unit tests with xUnit.net.
Supported platforms:
- Desktop .NET 4.5+
- .NET Core (Universal Windows Apps 10+, DNX Core 5+)
- Windows 8
- Windows Phone 8 (Silverlight)
- Universal (Windows Phone 8.1+, Windows 8.1+)
- Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal)
- Portable Libraries (supporting Profile259)
|
1 |
|
xunit.core
Includes the libraries for writing unit tests with xUnit.net.
Supported platforms:
- Desktop .NET 4.5+
- .NET Core (Universal Windows Apps 10+, DNX Core 5+)
- Windows Phone 8 (Silverlight)
- Universal (Windows Phone 8.1+, Windows 8.1+)
- Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal)
- Portable Libraries (supporting Profile259)
|
1 |
|
FSharp.Core
FSharp.Core redistributables from Visual F# Tools version 10.1 For F# 4.1
Supported Platforms:
.NET 4.5+ (net45)
netstandard1.6 (netstandard1.6)
netstandard2.0 (netstandard2.0)
|
1 |
|
System.IO.IsolatedStorage
Provides classes that allow the creation and use of isolated stores.
Commonly Used Types:
System.IO.IsolatedStorage.IsolatedStorageFile
System.IO.IsolatedStorage.IsolatedStorageFileStream
When using NuGet 3.x this package requires at least version 3.4.
|
1 |
|
FluentAssertions
A very extensive set of extension methods that allow you to more naturally specify the expected outcome of a TDD or
BDD-style unit test. Runs on 4.0 and 4.5 (Desktop and Windows Store), CoreCLR, Silverlight 5 and Windows Phone 8, 8.1 and 8.1 for Silverlight. Supports the unit test frameworks NUnit, XUnit, XUnit2, MBUnit, Gallio, MSpec, and NSpec.
|
1 |
|
FSharp.Core
FSharp.Core redistributables from Visual F# Tools version 10.2 For F# 4.5
Supported Platforms:
.NET 4.5+ (net45)
netstandard1.6 (netstandard1.6)
netstandard2.0 (netstandard2.0)
Commit hash: bfa5fdf264c7e242b9f0436b2bf45b76e70fdeac.
|
1 |
|
Portable.BouncyCastle
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR
IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you.
Crypto features:
- Generation and parsing of PKCS-12 files.
- X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates.
- PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256.
- Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA.
- Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20.
- Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR).
- Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte.
- Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding).
- Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1.
- AEAD block cipher modes: CCM, EAX, GCM and OCB.
- Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool.
- XOFs: SHAKE.
- Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998.
- Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a.
- Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC.
- PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2.
- OpenPGP (RFC 4880)
- Cryptographic Message Syntax (CMS, RFC 3852), including streaming API.
- Online Certificate Status Protocol (OCSP, RFC 2560).
- Time Stamp Protocol (TSP, RFC 3161).
- TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available.
- Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves.
- Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions.
- PKIX certificate path validation
|
1 |
|
FSharp.Core
FSharp.Core for F# 4.1
FSharp.Core redistributables from Visual F# 4.1.0
.NET 2.0
.NET 4.0
.NET Portable Profile 7 (portable-net45+netcore45)
.NET Portable Profile 47 (portable-net45+sl5+netcore45)
.NET Portable Profile 78 (portable-net45+netcore45+wp8)
.NET Portable Profile 259 (portable-net45+netcore45+wpa81+wp8)
.NET Standard 1.6 (netstandard1.6)
FSharp.Core built by F# Software Foundation
MonoAndroid, MonoTouch, Xamarin.iOS (portable-net45+monoandroid10+monotouch10+xamarinios10)
XamarinMac mobile (xamarinmac20)
|
1 |
|
System.Collections.Concurrent
Provides several thread-safe collection classes that should be used in place of the corresponding types in the System.Collections.NonGeneric and System.Collections packages whenever multiple threads are accessing the collection concurrently.
Commonly Used Types:
System.Collections.Concurrent.ConcurrentDictionary<TKey, TValue>
System.Collections.Concurrent.ConcurrentQueue<T>
System.Collections.Concurrent.ConcurrentBag<T>
System.Collections.Concurrent.BlockingCollection<T>
System.Collections.Concurrent.ConcurrentStack<T>
When using NuGet 3.x this package requires at least version 3.4.
|
1 |
|
FSharp.Core
FSharp.Core redistributables from Visual F# 4.1.0
Supported Platforms:
.NET 4.5+ (net45)
netstandard1.6 (netstandard1.6)
|
1 |
MonoAndroid 1.0
- No dependencies.
MonoTouch 1.0
- No dependencies.
.NET Framework 4.5
- No dependencies.
.NETCore 5.0
- Microsoft.NETCore.Platforms (>= 1.1.0)
- Microsoft.NETCore.Targets (>= 1.1.0)
- System.Runtime (>= 4.3.0)
.NET Standard 1.0
- Microsoft.NETCore.Platforms (>= 1.1.0)
- Microsoft.NETCore.Targets (>= 1.1.0)
- System.Runtime (>= 4.3.0)
.NET Standard 1.3
- Microsoft.NETCore.Platforms (>= 1.1.0)
- Microsoft.NETCore.Targets (>= 1.1.0)
- System.Runtime (>= 4.3.0)
.NETPortable 0.0
- No dependencies.
Windows 8.0
- No dependencies.
WindowsPhone 8.0
- No dependencies.
WindowsPhoneApp 8.1
- No dependencies.
Xamarin.iOS 1.0
- No dependencies.
Xamarin.Mac 2.0
- No dependencies.
Xamarin.TVOS 1.0
- No dependencies.
Xamarin.WatchOS 1.0
- No dependencies.
| Version | Downloads | Last updated |
|---|---|---|
| 4.3.0 | 0 | 11/15/2016 |
| 4.3.0-preview1-24530-04 | 0 | 10/24/2016 |
| 4.0.11 | 0 | 06/27/2016 |
| 4.0.11-rc2-24027 | 0 | 05/16/2016 |
| 4.0.11-beta-23516 | 0 | 11/18/2015 |
| 4.0.11-beta-23409 | 0 | 10/15/2015 |
| 4.0.11-beta-23225 | 0 | 09/02/2015 |
| 4.0.10 | 0 | 07/29/2015 |
| 4.0.10-beta-23109 | 0 | 07/27/2015 |
| 4.0.10-beta-23019 | 0 | 06/30/2015 |
| 4.0.10-beta-22816 | 0 | 04/24/2015 |
| 4.0.10-beta-22605 | 0 | 02/13/2015 |
| 4.0.10-beta-22416 | 0 | 01/16/2015 |
| 4.0.10-beta-22231 | 0 | 11/11/2014 |
| 4.0.0 | 0 | 07/29/2015 |
| 4.0.0-beta-23109 | 0 | 07/27/2015 |
| 4.0.0-beta-23019 | 0 | 06/30/2015 |
| 3.1.1 | 0 | 10/18/2014 |
| 3.0.2-beta2 | 0 | 05/15/2012 |
| 3.0.2-beta1 | 0 | 05/14/2012 |
| 3.0.1 | 0 | 04/11/2012 |
| 3.0.0 | 0 | 03/24/2012 |
| 2.1.2 | 0 | 09/03/2011 |
| 2.1.1 | 0 | 09/02/2011 |
| 2.1.0 | 0 | 09/02/2011 |
| 2.0.1 | 0 | 08/25/2011 |
| 2.0.0 | 0 | 08/22/2011 |