OpenTK.Input by: Team OpenTK
  • 42 total downloads
  • Latest version: 4.9.4
  • opentk;opengl;cross-platform;openal;csharp;fsharp;vb;dotnet;mono;graphics;game;scientific;science;3d;2d;math;input;gamepad;joystick
Hid/Controller input library.
OpenTK.Mathematics by: Team OpenTK
  • 1 total downloads
  • Latest version: 4.0.0-pre9.4
A basic mathematics library developed primarily for rendering in 3d and 2d.
OpenTK.redist.glfw by: Team OpenTK
  • 19 total downloads
  • Latest version: 3.5.1.71
GLFW redistributables for OpenTK.
OpenTK.Windowing.Common by: Team OpenTK
  • 1 total downloads
  • Latest version: 4.0.0-pre9.4
Common functionality for OpenTK.Windowing.* packages.
OpenToolkit.Core by: Team OpenTK
  • 13 total downloads
  • Latest version: 4.0.0-pre9.3
Holds core functionality used by other OpenToolkit packages.
OpenToolkit.Graphics by: Team OpenTK
  • 13 total downloads
  • Latest version: 4.0.0-pre9.3
GLes11, GLes20, GLes30, GL2, and GL4 bindings for dotnet from the Khronos openGL c library.
OpenToolkit.Input by: Team OpenTK
  • 13 total downloads
  • Latest version: 4.0.0-pre9.3
Hid/Controller input library.
OpenToolkit.Mathematics by: Team OpenTK
  • 13 total downloads
  • Latest version: 4.0.0-pre9.3
A basic mathematics library developed primarily for rendering in 3d and 2d.
opentoolkit.redist.glfw by: OpenToolkit
  • 1 total downloads
  • Latest version: 3.3.0-pre20200829200313
GLFW redistributables for OpenTK.
OpenToolkit.Windowing.Common by: Team OpenTK
  • 15 total downloads
  • Latest version: 4.0.0-pre9.3
Common functionality for OpenToolkit.Windowing.* packages.
OrleansDashboard by: OrleansContrib
  • 4 total downloads
  • Latest version: 2.3.1
  • orleans dashboard metrics monitor
An admin dashboard for Microsoft Orleans
Parlot by: Sebastien Ros
  • 9 total downloads
  • Latest version: 2.3.1
  • parser interpreter
Parlot is a fast, lightweight and simple to use .NET parser combinator.
PCLStorage by: Daniel Plaisted
  • 1 total downloads
  • Latest version: 1.0.2
  • io storage file portable pcl winrt android ios xamarin monoandroid monodroid monotouch
PCL Storage provides a consistent, portable set of local file IO APIs for .NET, Windows Phone, Windows Store, Xamarin.iOS, Xamarin.Android, and Silverlight. This makes it easier to create cross-platform .NET libraries and apps.
Pipelines.Sockets.Unofficial by: Pipelines.Sockets.Unofficial
  • 1 total downloads
  • Latest version: 1.1.23
Package Description
Polly by: Michael Wolfenden, App vNext
  • 2 total downloads
  • Latest version: 8.9.0
  • Polly Exception Handling Resilience Transient Fault Policy Circuit Breaker CircuitBreaker Retry Wait Cache Cache-aside Bulkhead Fallback Timeout Throttle
Polly is a .NET resilience and transient-fault-handling library that allows developers to express resilience and transient fault handling policies such as Retry, Circuit Breaker, Timeout, Bulkhead Isolation, and Fallback in a fluent and thread-safe manner.
Portable.BouncyCastle by: Oren Novotny
  • 1 total downloads
  • Latest version: 1.8.0
  • bouncycastle cryptography encryption security PCL wp8 wpa81 coreclr dotnet dnx uwp sl5 monotouch monoandroid xamarin xamarin.ios
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you. Crypto features: - Generation and parsing of PKCS-12 files. - X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. - PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. - Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. - Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20. - Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). - Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte. - Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding). - Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1. - AEAD block cipher modes: CCM, EAX, GCM and OCB. - Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool. - XOFs: SHAKE. - Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998. - Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a. - Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC. - PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2. - OpenPGP (RFC 4880) - Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. - Online Certificate Status Protocol (OCSP, RFC 2560). - Time Stamp Protocol (TSP, RFC 3161). - TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available. - Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves. - Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions. - PKIX certificate path validation
PreMailer.Net by: Martin H. Normark
  • 6 total downloads
  • Latest version: 2.7.4
  • email css newsletter html
PreMailer.Net is a C# utility for moving CSS to inline style attributes, to gain maximum E-mail client compatibility.
RabbitMQ.Client by: Broadcom
  • 3 total downloads
  • Latest version: 7.3.0-beta.0
  • rabbitmq, amqp
The RabbitMQ .NET client is the official client library for C# (and, implicitly, other .NET languages)
RazorLight by: toddams
  • 1 total downloads
  • Latest version: 1.0.0-rc1
Use Razor template engine to parse strings / files / EmbeddedResources for .NET Core
Reloadify3000 by: James Clancey
  • 1 total downloads
  • Latest version: 1.0.7
Hot Reload plugin for Comet