BenchmarkDotNet.Annotations
by: .NET Foundation and contributors
- 16 total downloads
- Latest version: 0.14.0
Powerful .NET library for benchmarking
BenchmarkDotNet.Core
by: .NET Foundation and contributors
- 5 total downloads
- Latest version: 0.10.3
Powerful .NET library for benchmarking
BenchmarkDotNet.Toolchains.Roslyn
by: .NET Foundation and contributors
- 5 total downloads
- Latest version: 0.10.3
Powerful .NET library for benchmarking
BlazorStrap
by: Chanan Braunstein, John Bomhold
- 127 total downloads
- Latest version: 5.2.105-RC-4
A bootstrap 5 component library for Blazor
BlazorStrap.V5
by: Chanan Braunstein, John Bomhold
- 47 total downloads
- Latest version: 5.2.105-RC-4
Bootstrap 5.x component library for BlazorStrap
Bogus
by: Brian Chavez
- 132 total downloads
- Latest version: 35.6.5
A simple and sane data generator for populating objects that supports different locales. A delightful port of the famed faker.js and inspired by FluentValidation. Use Bogus to create UIs with fake data or seed databases. Get started by using Faker class or a DataSet directly.
bootstrap
by: The Bootstrap Authors
- 75 total downloads
- Latest version: 6.0.0-alpha.1
The most popular front-end framework for developing responsive, mobile first projects on the web.
BouncyCastle
by: Bouncy Castle Project Contributors
- 1 total downloads
- Latest version: 1.8.1
- Generation and parsing of PKCS-12 files.
- X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates.
- PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256.
- Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA.
- Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20.
- Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR).
- Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte.
- Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding).
- Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1.
- AEAD block cipher modes: CCM, EAX, GCM and OCB.
- Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool.
- XOFs: SHAKE.
- Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998.
- Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a.
- Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC.
- PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2.
- OpenPGP (RFC 4880)
- Cryptographic Message Syntax (CMS, RFC 3852), including streaming API.
- Online Certificate Status Protocol (OCSP, RFC 2560).
- Time Stamp Protocol (TSP, RFC 3161).
- TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available.
- Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves.
- Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions.
- PKIX certificate path validation
Castle.Core
by: Castle Project Contributors
- 1 total downloads
- Latest version: 4.4.1
Castle Core, including DynamicProxy, Logging Abstractions and DictionaryAdapter
CommandLineParser
by: gsscoder, nemec, ericnewton76, moh-hassan
- 2 total downloads
- Latest version: 2.9.1
Terse syntax C# command line parser for .NET. For FSharp support see CommandLineParser.FSharp. The Command Line Parser Library offers to CLR applications a clean and concise API for manipulating command line arguments and related tasks.
CommonServiceLocator
by: .NET Foundation and Contributors
- 1 total downloads
- Latest version: 2.0.7
The library provides an abstraction over IoC containers and service locators. Using the library allows an application to indirectly access the capabilities without relying on hard references.
ConsoleAppFramework
by: Cysharp
- 2 total downloads
- Latest version: 5.7.12
Zero Dependency, Zero Overhead, Zero Reflection, Zero Allocation, AOT Safe CLI Framework powered by C# Source Generator.
Crc32.NET
by: force
- 1 total downloads
- Latest version: 1.2.0
Fast version of Crc32 & Crc32C algorithms for .NET and .NET Core. It is up to 3x-5x times better than other "fast" implemenations. Code based on Crc32C.NET library.
CsQuery
by: James Treworgy
- 1 total downloads
- Latest version: 1.3.4-beta1
CsQuery is an HTML parser, CSS selector engine and jQuery port for .NET 4 and C#. It implements all CSS2 and CSS3 selectors, all the DOM manipulation methods of jQuery, and some of the utility methods.
CsvHelper
by: Josh Close
- 2 total downloads
- Latest version: 3.0.0-beta7
A library for reading and writing CSV files. Extremely fast, flexible, and easy to use. Supports reading and writing of custom class objects.
Cucumber.Messages
by: Cucumber Ltd, TechTalk
- 1 total downloads
- Latest version: 21.0.1
Protocol Buffer messages for Cucumber's and SpecFlow's inter-process communication
deniszykov.WebSocketListener
by: Valeriano Tortola, Denis Zykov
- 1 total downloads
- Latest version: 4.2.19
A lightweight and highly scalable asynchronous WebSocket listener for .NET Core, .NET and Mono.
https://github.com/deniszykov/WebSocketListener
diskann-garnet
by: Microsoft
- 15 total downloads
- Latest version: 9.0.0
DiskANN FFI and Data Provider for Garnet
DocumentFormat.OpenXml
by: Microsoft
- 2 total downloads
- Latest version: 3.5.1
The Open XML SDK provides tools for working with Office Word, Excel, and PowerPoint documents. It supports scenarios such as:
- High-performance generation of word-processing documents, spreadsheets, and presentations.
- Populating content in Word files from an XML data source.
- Splitting up (shredding) a Word or PowerPoint file into multiple files, and combining multiple Word/PowerPoint files into a single file.
- Extraction of data from Excel documents.
- Searching and replacing content in Word/PowerPoint using regular expressions.
- Updating cached data and embedded spreadsheets for charts in Word/PowerPoint.
- Document modification, such as removing tracked revisions or removing unacceptable content from documents.
DocumentFormat.OpenXml.Framework
by: Microsoft
- 0 total downloads
- Latest version: 3.1.0
The Open XML SDK provides tools for working with Office Word, Excel, and PowerPoint documents. It supports scenarios such as:
- High-performance generation of word-processing documents, spreadsheets, and presentations.
- Populating content in Word files from an XML data source.
- Splitting up (shredding) a Word or PowerPoint file into multiple files, and combining multiple Word/PowerPoint files into a single file.
- Extraction of data from Excel documents.
- Searching and replacing content in Word/PowerPoint using regular expressions.
- Updating cached data and embedded spreadsheets for charts in Word/PowerPoint.
- Document modification, such as removing tracked revisions or removing unacceptable content from documents.